노무현 대통령 배너

Make A Wish!!

SERAPHMATe's LifeLog


※ 원문은 GExperts - WebCenter Interaction and RAC임을 알립니다.

1. RAC관련 설정이 완료된 tnsnames.ora 파일을 PT_HOME/settings 디렉토리에 복사합니다.

RAC = 
    (DESCRIPTION = 
        (ADDRESS_LIST= 
            (FAILOVER = ON) // Connection-Time Failover 
            (LOAD_BALANCE = ON) // Client Load x 
            (ADDRESS= (PROTOCOL = TCP)(HOST = rac1)(PORT = 1521)) 
            (ADDRESS= (PROTOCOL = TCP)(HOST = rac2)(PORT = 1521)) 
        )
        (CONNECT_DATA= 
            (SERVICE_NAME = PLUM10.plumtree.com) 
        ) 
    )

2. PT_HOME/settings 아래에 있는 configuration.xml 파일을 열어 다음과 같은 항목을 찾습니다.



3. 해당 항목 아래 줄에 다음의 코드를 추가합니다.


    C:/alui65/settings/tnsnames.ora


    RAC

이 때, rac-tnsnames-file의 value는 tnsnames.ora 파일의 실제 경로를 사용하고, rac-tnsnames-data-source의 value는 tnsnames.ora에 설정한 이름을 사용합니다.(처음 "=" 표시 앞에 있는 이름입니다.)

4. configuration.xml 파일에 DB 관련 설정 부분을 찾아서 앞의 내용을 반복합니다.



직접 테스트해보지는 못했는데 한책임님 요청으로 문서를 찾다 발견한 포스트를 번역해서 올립니다. 도움이 되길 바랍니다.


  1. 2012.07.04 10:42 Delete Reply Permalink

    비밀댓글입니다

Leave a comment

plumtreeserver.jar
ptportalobjects.jar
pthome.jar
portal.jar
openconfig.jar
openkernel.jar
openkernelsearch_4-3.jar
opencounters.jar
opendb.jar
dbutils.jar
connectionpool.jar
ploracle.jar(아마 PORTAL DB가 다른 경우 plsql.jar등으로 맞추면 될듯)
plbase.jar(Pool을 쓰는데 기본되는 Driver인듯)
plutil.jar
opencache.jar
openhttp.jar
opentempfile.jar
Leave a comment

테스트 및 스터디 용으로 WebCenter Interaction을 다시 설치하고 있다.

EDelivery에서 찾아보니 Windows 64Bit용이 있길래 "호오~"하고 다운 받아서 설치하는데

뭔가 설치 과정이 이상한거다 -_-

웹서버 설정도 예전처럼 Apache / Other 선택도 없고,
.Net인지 Java플랫폼인지 선택도 안나오고 -_-;

플랫폼 선택이고 뭐고 아무것도 안나와서 silent모드로 설치를 진행하고나서 DB 생성하고, 스크립팅하고 Configuration Manager접속할려고보니 접속이 안되서, Window Service가 실행 안되었나해서 Services.msc를 실행했는데,

CM관련 서비스가 없는 거다 -_-;
그래서 Command모드에서 실행하려고 CM디렉토리에 갔는데 실행파일이 들어있을 bin 디렉토리가 없는거다 -_-;

설치가 잘못된건가 싶어서 다시 인스톨러로 설치를 진행했다. 근데 인스톨러에서 0x8007000B관련 오류를 막 띄운다.

아놔~ 이거 뭐야 하고 오류코드로 찾아보니 인스톨러 자체가 32bit 기반으로 컴파일 된거라 64bit에서 인스톨러 자체가 실행이 요상한 모양이 된거 같았다.

그래서 호환성 모드를 XP 서비스팩 3로 주고 진행했더니 예전처럼 플랫폼 선택, 웹서버 선택 등의 옵션이 모두 인스톨러를 통해 진행된다.

역시 못 믿을 Oracle -_-;


<이어서 작성 중>

우여곡절 끝에 설정을 다 하고 CM에서 구성하고, Weblogic 도메인 만들고 DB 스크립팅 하고 일련의 과정을 진행한 후, WebLogic에 Deploy하고 구동을 하는데...

안된다...OTL.... 지원하지 않는 플랫폼이라나 뭐라나 하면서 LINUX용 JDK는 사용할 수 없으니 JDK 1.4이상으로 설치하라고 하는데...

나 JDK 1.6이거든 -_-; 왠지 64Bit용 JDK와 32Bit용 JDK라 헷갈리는 모양이다.... 후....


Leave a comment